Tuesday, 24 May 2016

Troubleshooting SAP HANA Delivery Units and HANA Live Packages issues. (HALM)

Whilst importing delivery units into your HANA System you can sometimes run into some common errors which can easily be fixed without the means of opening a SAP Incident.

Lets look at an example.

Here you are importing SAP HANA Analytics into your system. During the import you see an error:

Troubleshooting SAP HANA Delivery Units and HANA Live Packages issues. (HALM).

To get a more in depth look a what actually went wrong here, we would need to look into the installation log (this is printed after the import fails) or the indexserver.trc file:

[37654]{228998}[123/-1] 2014-04-07 23:24:06.604933 e REPOSITORY       activator.cpp(01179) : Repository: Activation failed for at least one object;At least one runtime reported an error during revalidation. Please see CheckResults for details.

The problem in such cases is the person who was responsible for the prerequisites for the import did not check SAP note 1781992 before starting the import.
It is very important to have the necessary tables in the SAP_ECC Schema or else the import will fail. Best thing to do if this fails is to compare the existing tables with the tables listed in the note:

select table_name from m_cs_tables where schema_name = 'SAP_ECC' order by table_name asc;

1: What do you do if the import is still failing after all the tables have been imported?

Check the tables for invalid attributes and make sure the tables are set up correctly. (This just involves recreating the table).

You should also note which Delivery Units have failed to import. Re-importing the Delivery Unit again is also a valid approach to fix activation or deployment errors.

2: What do I do if the activation of some of views is failing after the import?

Make sure that when the tables are being searched in the schema, that it is searching the correct schema, this will involve insuring you have your schema mapping done correctly. An example of this can be seen in the below trace:

One table for a calculation view was searched in schema DT4_XT5: "- CalculationNode(WRF_CHARVALT): ColumnTable DT4_XT5:WRF_CHARVALT not found (cannot get catalog object)."

When searching this schema doesn't exist. Therefore the activation of "sap.is.retail.ecc.RetailCharacteristicValue" will obviously fail. So now you have to ask yourself the question, what schema did I start the installation with, did I start with a different schema and change it somewhere in between the process? Also check to see if you moved the "WRF_CHARDVALT" table elsewhere.

3: What if the user does not have the required privileges when activating CAR HANA Content or any other content?

When checking the logs you see errors with activation which refer to, lets say SAP_CRM schema. When looking for this schema in the catalog you cannot see it, so this leads to the question, does this actually exist or is my user prohibited from viewing this? The answer which is most likely is the lather. Make sure your user has been granted the SELECT privilege on the SAP_CRM schema. A good guide would be to follow SAP Note 1936727

So referring to the Note, you could check the _SYS_REPO to see if any important privileges are missing such as EXECUTE, INSERT, etc. Please note that normally the _SYS_REPO normally only needs the SELECT privilege for a plain installation.

4: What if you face errors when importing HANA SMART BUSINESS FOR ERP 1.0?

Checking the installation log after the import fails you see:

Object: sap.hba.r.sappl604::BSMOverview.calculationview ==> Error Code: 40117 Severity: 3
Object: sap.hba.r.sappl604::BSMOverview.calculationview ==> Repository: Encountered an error in repository runtime extension;Model inconsistency. Create Scenario failed:


ColumnView _SYS_BIC:sap.hba.r.sappl604/BSMInfoOverview not found (cannot get catalog object)(CalculationNode (BSMInfoOverview))


The following errors occured: Inconsistent calculation model (34011)
Details (Errors):
- CalculationNode (BSMInfoOverview): ColumnView _SYS_BIC:sap.hba.r.sappl604/BSMInfoOverview not found (cannot get catalog object).

The solution for this can be found in SAP Note 2317634

5: You receive errors when performing data previews on the package sap.hba.ecc?

When viewing the sap.hba.ecc packages you can see some calculation views are marked red. When clicking on data preview you see error:

Troubleshooting SAP HANA Delivery Units and HANA Live Packages issues. (HALM).

What we now need to ask is, did any of these views ever work at all or is it specific to individual views? If you answered "yes" to the first question, then I would re-deploy the delivery unit again which should fix this issue.

If it is specific views that are causing the issue, then try to re-deploy each view separately through Studio and activate again. If this does not work then work go into the Diagnosis Files tab in the HANA Studio and pull down the most recent errors which should have been printed in the indexserver.trc file. Check to see which table is trying to be reached for this view and what schema it is in. Check if the user you are logged in with has the correct privileges along with the _SYS_REPO.

The solution for this can also be found in SAP Note 2318731.

Source: scn.sap.com

2 comments: